$re = '~^(?=[^a-z]*[a-z]).*?A(?=B).*~m';
$str = 'ABCabc (valid)
abcABCabc (valid)
abcabc (not valid)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);