re = /^(?=[^a-z]*[a-z]).*?A(?=B).*/m
str = 'ABCabc (valid)
abcABCabc (valid)
abcabc (not valid)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end