#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?:" & @CRLF & _
" \G(?!\A)[-\/]" & @CRLF & _
" |" & @CRLF & _
" ^" & @CRLF & _
" [^-\d\/\n]*+" & @CRLF & _
" (?>[-\d\/]+[^-\d\/\n]+)*" & @CRLF & _
")" & @CRLF & _
"\K \d++ (?![-\/]\D)"
Local $sString = "" & @CRLF & _
" Name 789, 10-mill 12-27b" & @CRLF & _
" Manufacturer XY-2822, 10-mill, 17-25b" & @CRLF & _
" Other Manufacturer 16b Part" & @CRLF & _
" Another Manufacturer FER M9000, 11-mill, 11-40" & @CRLF & _
" 18b Part" & @CRLF & _
" Maker 11-31, 10-mill" & @CRLF & _
" Maker 1x or 2x; max size 1x (34b), 2x (38/24b)" & @CRLF & _
" Maker REC6 15/18/26b. Square." & @CRLF & _
" Producer FC-40 11-13-16-19-22-25-27-30-34b" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")