const regex = /(?:
\G(?!\A)[-\/]
|
^
[^-\d\/\n]*+
(?>[-\d\/]+[^-\d\/\n]+)*
)
\K \d++ (?![-\/]\D)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:
\\G(?!\\A)[-\\\/]
|
^
[^-\\d\\\/\\n]*+
(?>[-\\d\\\/]+[^-\\d\\\/\\n]+)*
)
\\K \\d++ (?![-\\\/]\\D)', 'gm')
const str = `
Name 789, 10-mill 12-27b
Manufacturer XY-2822, 10-mill, 17-25b
Other Manufacturer 16b Part
Another Manufacturer FER M9000, 11-mill, 11-40
18b Part
Maker 11-31, 10-mill
Maker 1x or 2x; max size 1x (34b), 2x (38/24b)
Maker REC6 15/18/26b. Square.
Producer FC-40 11-13-16-19-22-25-27-30-34b
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}