package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)([a-zA-Z].*?={.*?})`)
var str = `message_type={any_text}&message_number={digits}&code={digits}&id={digits}&message={any_text}×tamp={digits_with_decimal}
message_type={any_text}&
message_type={=}&id={&}&z={*&&=}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}