$re = '/([a-zA-Z].*?={.*?})/im';
$str = 'message_type={any_text}&message_number={digits}&code={digits}&id={digits}&message={any_text}×tamp={digits_with_decimal}
message_type={any_text}&
message_type={=}&id={&}&z={*&&=}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);