const regex = /(.*?[0-9]+?0)0+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?[0-9]+?0)0+$', '')
const str = `ZW0=2400850000000`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);