$re = '/(.*?[0-9]+?0)0+$/';
$str = 'ZW0=2400850000000';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;