using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\{(?=(?:""[^""]+""(?:, ?|(?=\})))*\})|(?!^)\G, ?)""([^""]+)""";
string input = @"{""aaa"",""bbb"", ""ccc"", ""d,d,d"",""kjhg*(%%^&^%&""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}