re = /(?:\{(?=(?:"[^"]+"(?:, ?|(?=\})))*\})|(?!^)\G, ?)"([^"]+)"/
str = '{"aaa","bbb", "ccc", "d,d,d","kjhg*(%%^&^%&"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end