using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https://)?discord\.com/invite/[a-zA-Z0-9]+";
string input = @"https://discord.com/invite/J8BDpEpnj7
discord.com/invite/J8BDpEpnj7
discord.com/invite/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}