// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https://)?discord\.com/invite/[a-zA-Z0-9]+").unwrap();
let string = "https://discord.com/invite/J8BDpEpnj7
discord.com/invite/J8BDpEpnj7
discord.com/invite/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}