#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w ]{1,3}(?= )|\w{1,3}|\{\w\})"
Local $sString = "1 {2 3}" & @CRLF & _
"1 2 3" & @CRLF & _
"1 23" & @CRLF & _
"{1}" & @CRLF & _
"{1 2}" & @CRLF & _
"123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")