$re = '/^([\w ]{1,3}(?= )|\w{1,3}|\{\w\})/m';
$str = '1 {2 3}
1 2 3
1 23
{1}
{1 2}
123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);