#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sUi)(BEGIN.*;.*END;)"
Local $sString = "DELETE FROM import WHERE NOT recstatus;" & @CRLF & _
"" & @CRLF & _
"ALTER TABLE import DROP COLUMN IF EXISTS erreur;" & @CRLF & _
"ALTER TABLE import ADD COLUMN erreur TEXT;" & @CRLF & _
"" & @CRLF & _
"DROP TRIGGER IF EXISTS line_error_seek_trigger ON import;" & @CRLF & _
"DROP FUNCTION IF EXISTS line_error_seek();" & @CRLF & _
"" & @CRLF & _
"CREATE OR REPLACE FUNCTION line_error_seek() RETURNS TRIGGER AS $errors_by_line$" & @CRLF & _
"BEGIN" & @CRLF & _
" blabla;" & @CRLF & _
" blablabla;" & @CRLF & _
" IF blabla" & @CRLF & _
" bla blaaaaaa;" & @CRLF & _
" END IF;" & @CRLF & _
" RETURN bla;" & @CRLF & _
"END;" & @CRLF & _
"$errors_by_line$ language 'plpgsql';" & @CRLF & _
"" & @CRLF & _
"CREATE TRIGGER line_error_seek_trigger" & @CRLF & _
" BEFORE UPDATE ON import" & @CRLF & _
" FOR EACH ROW" & @CRLF & _
" EXECUTE PROCEDURE line_error_seek();" & @CRLF & _
" " & @CRLF & _
"DROP FUNCTION IF EXISTS table_error_seek();" & @CRLF & _
"" & @CRLF & _
"CREATE OR REPLACE FUNCTION table_error_seek() RETURNS INTEGER AS $errors_by_table$" & @CRLF & _
"BEGIN" & @CRLF & _
" blabla;" & @CRLF & _
" blablabla;" & @CRLF & _
" RETURN bla;" & @CRLF & _
"END;" & @CRLF & _
"$errors_by_table$ LANGUAGE plpgsql;" & @CRLF & _
"" & @CRLF & _
"SELECT * FROM table_error_seek();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")