use strict;
my $str = 'DELETE FROM import WHERE NOT recstatus;
ALTER TABLE import DROP COLUMN IF EXISTS erreur;
ALTER TABLE import ADD COLUMN erreur TEXT;
DROP TRIGGER IF EXISTS line_error_seek_trigger ON import;
DROP FUNCTION IF EXISTS line_error_seek();
CREATE OR REPLACE FUNCTION line_error_seek() RETURNS TRIGGER AS $errors_by_line$
BEGIN
blabla;
blablabla;
IF blabla
bla blaaaaaa;
END IF;
RETURN bla;
END;
$errors_by_line$ language \'plpgsql\';
CREATE TRIGGER line_error_seek_trigger
BEFORE UPDATE ON import
FOR EACH ROW
EXECUTE PROCEDURE line_error_seek();
DROP FUNCTION IF EXISTS table_error_seek();
CREATE OR REPLACE FUNCTION table_error_seek() RETURNS INTEGER AS $errors_by_table$
BEGIN
blabla;
blablabla;
RETURN bla;
END;
$errors_by_table$ LANGUAGE plpgsql;
SELECT * FROM table_error_seek();';
my $regex = qr@(BEGIN.*;.*END;)@sip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}