#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0)(1?[0-9]{0,9}|20[0-9]{8}|21[0-3][0-9]{7}|214[0-6][0-9]{6}|2147[0-3][0-9]{5}|21474[0-7][0-9]{4}|214748[0-2][0-9]{3}|2147483[0-5][0-9]{2}|21474836[0-3][0-9]|214748364[0-7])$"
Local $sString = "1999999999" & @CRLF & _
"2055194264" & @CRLF & _
"2139898979" & @CRLF & _
"2146959544" & @CRLF & _
"2147384841" & @CRLF & _
"2147479101" & @CRLF & _
"2147482900" & @CRLF & _
"2147483566" & @CRLF & _
"2147483638" & @CRLF & _
"2147483639" & @CRLF & _
"9999999999" & @CRLF & _
"999999999" & @CRLF & _
"99999999" & @CRLF & _
"9999999" & @CRLF & _
"999999" & @CRLF & _
"99999" & @CRLF & _
"9999" & @CRLF & _
"999" & @CRLF & _
"99" & @CRLF & _
"9" & @CRLF & _
"0" & @CRLF & _
"01" & @CRLF & _
"012" & @CRLF & _
"0123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")