import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!0)(1?[0-9]{0,9}|20[0-9]{8}|21[0-3][0-9]{7}|214[0-6][0-9]{6}|2147[0-3][0-9]{5}|21474[0-7][0-9]{4}|214748[0-2][0-9]{3}|2147483[0-5][0-9]{2}|21474836[0-3][0-9]|214748364[0-7])$";
final String string = "1999999999\n"
+ "2055194264\n"
+ "2139898979\n"
+ "2146959544\n"
+ "2147384841\n"
+ "2147479101\n"
+ "2147482900\n"
+ "2147483566\n"
+ "2147483638\n"
+ "2147483639\n"
+ "9999999999\n"
+ "999999999\n"
+ "99999999\n"
+ "9999999\n"
+ "999999\n"
+ "99999\n"
+ "9999\n"
+ "999\n"
+ "99\n"
+ "9\n"
+ "0\n"
+ "01\n"
+ "012\n"
+ "0123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}