import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!//).)*?(ga.+(set)\\b.+(,).+(anonymizeIp)\\b.+(,).+(true|[1]{1})\\b)(?!(?:(?!/\\*)[\\s\\S])*\\*/)";
final String string = "(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){\n"
+ " (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),\n"
+ " m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)\n"
+ " })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');\n\n"
+ " ga('create', 'UA-XXXXX-Y', 'auto');\n"
+ " ga('send', 'pageview');\n"
+ " \n"
+ " // ga('set', 'anonymizeIp', true);";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}