re = /^(?:(?!\/\/).)*?(ga.+(set)\b.+(,).+(anonymizeIp)\b.+(,).+(true|[1]{1})\b)(?!(?:(?!\/\*)[\s\S])*\*\/)/im
str = '(function(i,s,o,g,r,a,m){i[\'GoogleAnalyticsObject\']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,\'script\',\'https://www.google-analytics.com/analytics.js\',\'ga\');
ga(\'create\', \'UA-XXXXX-Y\', \'auto\');
ga(\'send\', \'pageview\');
// ga(\'set\', \'anonymizeIp\', true);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end