$re = '/(([a-zA-Z]+)\,)|(\,[a-zA-Z]+)|([a-zA-Z]+)\(([a-zA-Z,]+)\)/';
$str = 'nombre,entidades,x(titulo,descripcion,fechaInicio),titulo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);