re = /(([a-zA-Z]+)\,)|(\,[a-zA-Z]+)|([a-zA-Z]+)\(([a-zA-Z,]+)\)/
str = 'nombre,entidades,x(titulo,descripcion,fechaInicio),titulo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end