using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![.,])\b0+([1-9])";
string substitution = @"$1";
string input = @"10/01/13 -> 10/1/13
10/10/13 -> no change
10/1/13 -> no change
01/10/13 -> 1/10/13
10,001.002";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}