re = /(?<![.,])\b0+([1-9])/
str = '10/01/13 -> 10/1/13
10/10/13 -> no change
10/1/13 -> no change
01/10/13 -> 1/10/13
10,001.002'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result