# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div\b[^<]*>(?:[^<]+(?:<(?!\\/?div\b)[^<]*)*|(?R))*<\\/div>\s*//ig;t' <<< "Text outside any div
<div id=\"my_id\"> bla bla
<div>
bla bla bla
<div style=\"some style here\">
lalalalala
</div>
</div>
I'm trapped in a div!
</div>
more text outside divs
<div>more divs here!
<div id=\"justbeingannoying\">radiohead rules</div>
</div>"