#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<div\b[^<]*>(?:[^<]+(?:<(?!\/?div\b)[^<]*)*|(?R))*<\/div>\s*"
Local $sString = "Text outside any div" & @CRLF & _
"<div id="my_id"> bla bla" & @CRLF & _
" <div>" & @CRLF & _
" bla bla bla" & @CRLF & _
" <div style="some style here">" & @CRLF & _
" lalalalala" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" I'm trapped in a div!" & @CRLF & _
"</div>" & @CRLF & _
"more text outside divs" & @CRLF & _
"" & @CRLF & _
"<div>more divs here!" & @CRLF & _
" <div id="justbeingannoying">radiohead rules</div>" & @CRLF & _
"</div>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)