import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9_-]+)\\/([a-zA-Z0-9_-]+)\\/[a-zA-Z0-9_-]";
final String string = "#good\n"
+ "grp/asd123/a/b\n"
+ "grp/asd123/a/b/c\n"
+ "grp/asd123/a\n\n"
+ "#bad\n"
+ "grp/project.git\n"
+ "grp/project.git/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}