$re = '/([a-zA-Z0-9_-]+)\/([a-zA-Z0-9_-]+)\/[a-zA-Z0-9_-]/';
$str = '#good
grp/asd123/a/b
grp/asd123/a/b/c
grp/asd123/a
#bad
grp/project.git
grp/project.git/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);