#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)<p\s*" & @CRLF & _
"(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*?\sclass=(['"]?)(?:body|bodydc)\1(?:\s|>)" & @CRLF & _
"" & @CRLF & _
"(?:([^<]*)|<(?!\/p)(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*>)*" & @CRLF & _
"(?=<\/p>)" & @CRLF & _
""
Local $sString = "<p class=bodyDC style='text-indent:12.0pt'><span style='font-size:14.0pt;" & @CRLF & _
"mso-bidi-font-size:10.0pt' onmouseover=" </p> ">We have no need to fear the future." So said" & @CRLF & _
"bishop-elect H. George Anderson at a news conference immediately following his election as " & @CRLF & _
"bishop of the Evangelical Lutheran Church in America. "[The" & @CRLF & _
"future] belongs to God, untouched by human hands." At the beginning of a" & @CRLF & _
"new ministry of leadership and pastoral oversight, such words from a bishop are" & @CRLF & _
"obviously designed to project confidence and a profound sense of trust in the" & @CRLF & _
"mission of the Church. They are words designed to inspire and empower the" & @CRLF & _
"people of God for ministry.<o:p></o:p></span></p>" & @CRLF & _
"Paragraph #2" & @CRLF & _
"" & @CRLF & _
"<p class=BODY><span style='font-size:14.0pt;mso-bidi-font-size:10.0pt'>Ages" & @CRLF & _
"ago, another prophet of the people stood at his station and peered into the" & @CRLF & _
"future. The<span style="mso-spacerun: yes"> </span>prophet Habakkuk poised on" & @CRLF & _
"the rampart, scanned the horizon for the approaching enemy he knew was coming." & @CRLF & _
"As he waited, Habakkuk prayed to God asking why God was unresponsive to all" & @CRLF & _
"this violence and destruction. In Habakkuk chapter 2 the prophet records God's" & @CRLF & _
"answer to his questions about the future. God says to the fearful one, "For" & @CRLF & _
"there is still a vision for the appointed time;… If it seems to tarry, wait for" & @CRLF & _
"it; it will surely come, it will not delay…the righteous live by faith"" & @CRLF & _
"(2:3-4).<o:p></o:p></span></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")