# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<p\s*
(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*?\sclass=(['"]?)(?:body|bodydc)\1(?:\s|>)
(?:([^<]*)|<(?!\/p)(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*>)*
(?=<\/p>)
"""
test_str = ("<p class=bodyDC style='text-indent:12.0pt'><span style='font-size:14.0pt;\n"
"mso-bidi-font-size:10.0pt' onmouseover=\" </p> \">We have no need to fear the future." So said\n"
"bishop-elect H. George Anderson at a news conference immediately following his election as \n"
"bishop of the Evangelical Lutheran Church in America. "[The\n"
"future] belongs to God, untouched by human hands." At the beginning of a\n"
"new ministry of leadership and pastoral oversight, such words from a bishop are\n"
"obviously designed to project confidence and a profound sense of trust in the\n"
"mission of the Church. They are words designed to inspire and empower the\n"
"people of God for ministry.<o:p></o:p></span></p>\n"
"Paragraph #2\n\n"
"<p class=BODY><span style='font-size:14.0pt;mso-bidi-font-size:10.0pt'>Ages\n"
"ago, another prophet of the people stood at his station and peered into the\n"
"future. The<span style=\"mso-spacerun: yes\"> </span>prophet Habakkuk poised on\n"
"the rampart, scanned the horizon for the approaching enemy he knew was coming.\n"
"As he waited, Habakkuk prayed to God asking why God was unresponsive to all\n"
"this violence and destruction. In Habakkuk chapter 2 the prophet records God's\n"
"answer to his questions about the future. God says to the fearful one, "For\n"
"there is still a vision for the appointed time;… If it seems to tarry, wait for\n"
"it; it will surely come, it will not delay…the righteous live by faith"\n"
"(2:3-4).<o:p></o:p></span></p>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.