$re = '/(.*)(\/products\/)(.*)(\.jpg)(.*)/m';
$str = 'https://cdn.mysite.com/a/files/1/0097/4192/6485/products/image.jpg?v=160';
$subst = "$1/files/$3-feed.jpg$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;