# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)(\/products\/)(.*)(\.jpg)(.*)"
test_str = "https://cdn.mysite.com/a/files/1/0097/4192/6485/products/image.jpg?v=160"
subst = "$1/files/$3-feed.jpg$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.