re = /\b(?:Bs|Usd)\b.*?(?=\s*Cuenta\b|$)/mi
str = 'Cuenta de Ahorros | 1231231231 Bs 102,423.88 Cuenta de Ahorros | 1231233123 Usd 102,423.88 Cuenta de Ahorros | 87316633 Usd 10.233 Cuenta de Ahorros | 49189387113313 Usd 12.301'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end