using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\X{0,30}$";
string substitution = @"";
string input = @"12345678901234567890123456789รค";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}