$re = '/^\X{0,30}$/u';
$str = '12345678901234567890123456789รค';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;