const regex = /<div class="row container-items">(.+?)\n<\/div>/us;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="row container-items">(.+?)\\n<\\\/div>', 'us')
const str = `<div class="row container-items">
<div class="col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block">
<div class="panel panel-default">
<div class="panel-body image-panel">
<a href="/p/{% p_link %}">
<div class="item_image">
<img src="/data/sorted/{% image_src %}">
</div>
</a>
</div>
<div class="panel-footer">
<div class="panel-heading category_view">
<div class="text-left">
<font color="#777">{% item_category %}</font>
</div>
<div class="text-right">{% count_view %}</div>
</div>
<!--<div class="caption_view">
{% item_caption %}
</div> -->
<a href="/p/{% p_link %}">посмотреть...</a>
</div>
</div>
</div>
<div class="col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block">
<div class="panel panel-default">
<div class="panel-body image-panel">
<a href="/p/{% p_link %}">
<div class="item_image">
<img src="/data/sorted/{% image_src %}">
</div>
</a>
</div>
<div class="panel-footer">
<div class="panel-heading category_view">
<div class="text-left">
<font color="#777">{% item_category %}</font>
</div>
<div class="text-right">{% count_view %}</div>
</div>
<!--<div class="caption_view">
{% item_caption %}
</div> -->
<a href="/p/{% p_link %}">посмотреть...</a>
</div>
</div>
</div>
<div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}