# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div class=\"row container-items\">(.+?)\n<\/div>"
test_str = ("<div class=\"row container-items\">\n\n"
"<div class=\"col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block\">\n"
" <div class=\"panel panel-default\">\n"
" <div class=\"panel-body image-panel\">\n"
" <a href=\"/p/{% p_link %}\">\n"
" <div class=\"item_image\">\n"
" <img src=\"/data/sorted/{% image_src %}\">\n"
" </div>\n"
" </a>\n"
" </div>\n"
" <div class=\"panel-footer\">\n"
" <div class=\"panel-heading category_view\">\n"
" <div class=\"text-left\">\n"
" <font color=\"#777\">{% item_category %}</font>\n"
" </div>\n"
" <div class=\"text-right\">{% count_view %}</div>\n"
" </div>\n"
" <!--<div class=\"caption_view\">\n"
" {% item_caption %}\n"
" </div> -->\n"
" <a href=\"/p/{% p_link %}\">посмотреть...</a>\n"
" </div>\n"
" </div>\n"
"</div>\n"
"<div class=\"col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block\">\n"
" <div class=\"panel panel-default\">\n"
" <div class=\"panel-body image-panel\">\n"
" <a href=\"/p/{% p_link %}\">\n"
" <div class=\"item_image\">\n"
" <img src=\"/data/sorted/{% image_src %}\">\n"
" </div>\n"
" </a>\n"
" </div>\n"
" <div class=\"panel-footer\">\n"
" <div class=\"panel-heading category_view\">\n"
" <div class=\"text-left\">\n"
" <font color=\"#777\">{% item_category %}</font>\n"
" </div>\n"
" <div class=\"text-right\">{% count_view %}</div>\n"
" </div>\n"
" <!--<div class=\"caption_view\">\n"
" {% item_caption %}\n"
" </div> -->\n"
" <a href=\"/p/{% p_link %}\">посмотреть...</a>\n"
" </div>\n"
" </div>\n"
"</div>\n\n"
"<div>")
matches = re.search(regex, test_str, re.UNICODE | re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.