package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i){([^}]+)}`)
var str = `{"a":1, "b":2}{"c":2,"e":3, "x":"ab{cd}efg"} `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}