$re = '/{([^}]+)}/i';
$str = '{"a":1, "b":2}{"c":2,"e":3, "x":"ab{cd}efg"} ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);