using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<smth\s)(.*?)(?=>)";
string input = @"<smth id=""test"">Hello World!</smth><?php echo ""Hello World!""?>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}