re = /(?<=<smth\s)(.*?)(?=>)/
str = '<smth id="test">Hello World!</smth><?php echo "Hello World!"?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end