import re
regex = re.compile(r"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~@#%=^*\-_+\[{}\]:./?!])(?!.*(.)(\1\1))[\w~@#%=^*\-_+\[{}\]:./?!]{8,64}$", flags=re.MULTILINE)
test_str = ("Password_pass\n"
"PASSWORD_123\n"
"Password123\n"
"Password_123\n\n\n"
"Password_123\n"
"Password_1233\n"
"Password_12333\n"
"Password__123\n"
"Password___123\n\n\n"
"Password#123\n"
"Password~123\n"
"Password?[]123\n\n"
"Pa_1234\n"
"Pa_12345\n"
"Pa_0123456789012345678901234567890123456789012345678901234567890\n"
"Pa_01234567890123456789012345678901234567890123456789012345678901")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")