const regex = /(?<=\.{3})(\S+?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\.{3})(\\S+?)', 'gm')
const str = ` x <- c(
".. ........ ....... ",
"... ........ ....... ",
". ..... ....... . .. ... .... ",
".. ..... ........... .... "
) `;
const subst = `i`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);