import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/(dev|www).pricewombat.com\\/d\\/[^ \\n]+)$";
final String string = "this is a test yo \n"
+ "test regexbuddy.com\n"
+ "www.regexbuddy.com\n"
+ "http://regexbuddy.com cvc\n"
+ "http://www.regexbuddy.com cvcv\n"
+ "http://www.regexbuddy.com/ g\n"
+ "http://www.regexbuddy.com/index.html f\n"
+ "http://www.regexbuddy.com/index.html?source=library f\n"
+ "You can download RegexBu ddy at http://www.regexbuddy.com/download.html. f\n"
+ "\"www.domain.com/quoted URL with spaces\"\n"
+ "http://10.2.2.1.2/ttxx/txt/gg v\n"
+ "support@regexbuddy.com\n\n"
+ "http://dev.pricewombat.com/d/4\n"
+ "http://www.pricewombat.com/d/12/Spalding-Premier-Excel-Basketball-15-Free-Store-Pickup";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}