$re = '/[2-3]0+/';
$str = 'HTTP/1.1 200 OK';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);