const regex = /(?<=\s|\||;|,|^)[\w.+-]+@(?:[\w-]+\.){1,2}(?:[a-z]{2,6})(?:\.[a-z]{2,6})?(?=\s|\||;|,|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s|\\||;|,|^)[\\w.+-]+@(?:[\\w-]+\\.){1,2}(?:[a-z]{2,6})(?:\\.[a-z]{2,6})?(?=\\s|\\||;|,|$)', 'g')
const str = `this is test string`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}