re = /(?<=\s|\||;|,|^)[\w.+-]+@(?:[\w-]+\.){1,2}(?:[a-z]{2,6})(?:\.[a-z]{2,6})?(?=\s|\||;|,|$)/
str = 'this is test string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end