const regex = /^((([A-Za-z][A-Za-z0-9]*[\.\_]*[A-Za-z0-9]+){0,30}@[a-z]{3,15}\.[a-z]{2,5})|(([A-Za-z][A-Za-z0-9]*[._]*[A-Za-z0-9]+){0,30}@[a-z]{3,15}\.[a-z]{2}\.[a-z]{2,5}))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((([A-Za-z][A-Za-z0-9]*[\\.\\_]*[A-Za-z0-9]+){0,30}@[a-z]{3,15}\\.[a-z]{2,5})|(([A-Za-z][A-Za-z0-9]*[._]*[A-Za-z0-9]+){0,30}@[a-z]{3,15}\\.[a-z]{2}\\.[a-z]{2,5}))$', '')
const str = `lkffdsl@gmail.co.co`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);