$re = '/(?:\(|\b)[\w]{3}\s*\)?[.-]?\s*[\w]{3}\s*[.-]\s*[\w]{3,4}\b/m';
$str = 'xxx.xxx.xxx
xxx-xxx-xxx
(xxx)xxx-xxxx
(xxx) xxx-xxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);