using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Parameter #\d+ \[ <(?:optional|required)> ([a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*(?:\\[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*)*)(?: or NULL)? \$[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*(?: = NULL)? \]$";
string input = @"Parameter #1 [ <optional> Namespaced\ClassName or NULL $className = NULL ]
Parameter #1 [ <required> Namespaced\ClassName $className ]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}